This topic contains 3 replies, has 2 voices, and was last updated by Sean Sean 2 years, 3 months ago.

jQuery


  • liane
    Participant

    Posts: 14
    Member Reply #7288

    I updated my jQuery to the latest version (3.1.0) and broke the admin (4.6)

    Looking at the plugins folder, it seems that the jQuery version provided with the theme is 1.12.1…

    Time to upgrade perhaps?

    Sean
    Sean
    Keymaster

    Posts: 4527
    Support Staff Reply #7300

    Hi,

    Noted. We will consider updating jquery with the latest version in the next update very soon. However we do not 100% confirm this update yet since the core 3rd party plugins might be compatible with latest jquery version yet.

    Thanks.


    liane
    Participant

    Posts: 14
    Member Reply #7315

    thanks.

    FWIW, Metronics runs perfectly with jQuery 2.2.4, so perhaps you should first move to this version, using the latest jQuery migrate (1.4.1, you’re using 1.2.1) it won’t break anything.

    The main problem I saw with jQuery 3 was the use of jQuery.fn.size() (deprecated since 1.8) in layout.js and app.js.

    Also, I don’t use all Metronics included plugins, but if some are not compatible and not willing to update, perhaps you should consider to deprecate them

    • This reply was modified 2 years, 3 months ago by  liane.
    Sean
    Sean
    Keymaster

    Posts: 4527
    Support Staff Reply #7329

    Hi :),

    Sure. We will consider this in the next update. Also we will try to make our custom JS code fully compatible with jQuery3. Stay tuned!

    Thanks.

     

You must be logged in to reply to this topic.