This topic contains 3 replies, has 3 voices, and was last updated by Zis Zis 3 years ago.

Left-menu not working when it is 'fixed' (multiple bugs)


  • pixievinayak
    Participant

    Posts: 9
    Member Reply #1521

    The left menu isn’t working when it’s set as ‘fixed’.

    This hasn’t been addressed in the 4.0 update and the problem still persists.

    This problem can easily be replicated in the online demo for the admin theme.

    1. From quick side bar change the “Sidebar Mode -> Fixed”.
    2. Click on the ‘hamburger’ icon to minimize the menu. (Don’t move your mouse after)
    3. You’ll see the menu not minimizing correctly.
    4. Also once you move your mouse out and the menu gets minimized, it is not possible to expand any of the sub menus now.
    5. Also moving your mouse over an icon in the minimized left menu, makes the whole menu pop-out which is very inconvenient. Only the sub-menu for the icon which was moved over should pop-out. Just like when the menu is not fixed.

    This is quite a big issue in the theme and for me, as I would be using a fixed left-menu in my application.

    The theme otherwise is FANTASTIC!

    Please please do help.

    Sean
    Sean
    Keymaster

    Posts: 4482
    Support Staff Reply #1540

    Hi :),

    Thanks for your feedback on this.

    Yes, there is a technical limitation if you use the fixed sidebar menu with the hamburger toggler button in it.
    As a workaround you can use the layout where the hamburger button is outside the sidebar menu:

    http://www.keenthemes.com/preview/metronic/theme/templates/admin/layout_sidebar_fixed.html

    If you need any further clarifications please let us know.

    To stay updated please follow us on http://twitter.com/keenthemes 😉

    Thanks.


    pixievinayak
    Participant

    Posts: 9
    Member Reply #1544

    Hi Sean,

    Thanks for that suggestion, I’ll use it, but even in the link you have included in your reply, the sub-menus don’t expand.

    Regards.

     

    Zis
    Zis
    Participant

    Posts: 150
    Support Staff Reply #1552

    Hi there,

    Thank you for reporting the bug issue. We have taken note and will fix it in the future releases.

    To stay updated please follow us on http://twitter.com/keenthemes

    Let us know if you have more questions to ask.

    Best Regards 😉

You must be logged in to reply to this topic.