This topic contains 8 replies, has 3 voices, and was last updated by Sean Sean 3 years, 4 months ago.

Menu not working


  • jlmc.jlmc21@gmail.com
    Participant

    Posts: 17
    Member Reply #2133

    Hi there,

    When I navigate to a page on my site, the menu’s active css does’t seem to take effect. Although I’m already navigated to the page I clicked, the active menu remains on the index page. I’m guessing it’s a javascript issue and I’ve tried to figure my way around with no avail. Could you please direct my attention to the correct place so I can try to fix the problem.

    • This topic was modified 3 years, 4 months ago by Sean Sean.

    Anonymous
    Support Staff Reply #2136

    Hi,

    Can you tell us what the menu you are using and provide us a test link to your developing site in a private reply (just check “set as a private reply”
    checkbox to make your replies visible only to support staff)? We will need to check your code only in order to advise you further.

    Thanks


    jlmc.jlmc21@gmail.com
    Participant

    Posts: 17
    Member Reply #2138
    This reply has been marked as private.
    Sean
    Sean
    Keymaster

    Posts: 4527
    Support Staff Reply #2142

    Hi,

    Can you provide a screenshot of the error message and include files with codes, so we can check it out further. Otherwise, we are not able to test your code to advise you further.


    jlmc.jlmc21@gmail.com
    Participant

    Posts: 17
    Member Reply #2143

    As requested.

    Image as attached. Highlighting how the page has been navigated to another page but the active menu still remains at the “enterprise” menu when it should be at the “user” menu.

    Attachments:
    You must be logged in to view attached files.

    jlmc.jlmc21@gmail.com
    Participant

    Posts: 17
    Member Reply #2149

    Please ignore the previous reply. The codes seems distorted after pasting it in. Please refer to the attached files instead.

    the text file is the codes which are formally in .jsp. There are no errors just that the menu do not function correctly.

    Attachments:
    You must be logged in to view attached files.
    Sean
    Sean
    Keymaster

    Posts: 4527
    Support Staff Reply #2211

    Hi,

    Please note, the active state of the menu link is set with css class “active” when you generate your page based on URL.
    For example please refer to the preview site: http://www.keenthemes.com/preview/metronic/theme/templates/admin/

    Using Chrome’s dev tools please inspect the active link in the sidebar menu and you can that it has “active” class.
    Using this “active” class in your JSP code you can conditionally set active menu link in your server side.

    I think you should get some advice from senior JSP developers(if you work in team) and they will be able to point you out as this is a sever side implementation issue.

    Thanks.


    jlmc.jlmc21@gmail.com
    Participant

    Posts: 17
    Member Reply #2252

    Hi Sean,

    Thanks for your reply. Perhaps you could direct my attention to the JSP file that sets the active class to the particular ul?

    Thanks

    Sean
    Sean
    Keymaster

    Posts: 4527
    Support Staff Reply #2263

    Hi,

    Sorry, we are not JSP experts so we are not able to provide you JSP integration for this. According to our support policy the backend part integration is not covered. For more info please check: http://themeforest.net/item/metronic-responsive-admin-dashboard-template/4021469/support

    Thanks.

Tagged: 

You must be logged in to reply to this topic.