This topic contains 3 replies, has 2 voices, and was last updated by Sean Sean 2 years, 9 months ago.

Using Metronic theme with asp.net web page causes browser to hang


  • madluka
    Participant

    Posts: 1
    Member Reply #1013

    Hi,

    I used to work with html a long, long time ago but never kept up with html5/css based design.  I am using Visual Studio 2013 to create an empty VB ASP.NET web application and I am transferring the demo admin dashboard code into my default.aspx and I have the dashboard template theme and most of the portlets, graphs and menu’s successfully working – however if I try to include the “TASKS” or “FEEDS” portlets, these cause the browser (both IE or chrome) to crash.  I can get the browser to work with TASKS or FEEDS provided that there are no list items.

    Is there anything special about these portlets that do not work with ASP.NET?  Is there something I need to be aware of using Metronic theme with VB/ASP.NET?

    Thanks!

    Sean
    Sean
    Keymaster

    Posts: 4206
    Support Staff Reply #1051

    Hi :),

    Your issue should not be related to .NET code since the theme is based on HTML, CSS and JS. I suspect the js files code required by those portlets are missing on your master page. For FEEDS portlet you don’t require anything special since its based on HTML & CSS only. Please refer to the original template and include the full HTML code for those portlets.

    If you need any further assistance please provide a test link to your developing site in a private reply(just check “set as a private reply” checkbox for your reply post).

    Thanks.


    madluka
    Participant

    Posts: 1
    Member Reply #1062

    Hi. Thanks for the reply. I actually have taken the entire html code from the index.html admin template and transferred this into a default.aspx, so I’m not sure that I am missing any other code? I have every component of the template working aside from those two portlets. The sliding side menu also works. The browser hangs when it encounters the first

  • items of the portlet.

     

Sean
Sean
Keymaster

Posts: 4206
Support Staff Reply #1088

Hi,

Can you provide us a test link to your site in a private reply(check “set as a private reply” checkbox before posting your reply)? Otherwise it will be hard to predict your issue since this is not a general issue but individual issue.

Thanks.

You must be logged in to reply to this topic.